[twsocket] WSocket.dcu file not found

Saige Losli saigel@ivex.com
Wed, 28 Jun 2000 10:21:37 -0700


Hi Wilfried,

I tried to do this, but I'm not sure I did it correctly. Here is what I did:

I select Tools | Environment Options, then I click on the Library tab. Once
there, I added the path of the WSocket.dcu to the "Library Path" directory.
Previously, it contained:

$(DELPHI)\Lib;$(DELPHI)\Bin;$(DELPHI)\Imports;$(DELPHI);c:\source\ivex\common

When I added the path to WSocket.dcu, it became:

$(DELPHI)\Lib;$(DELPHI)\Bin;$(DELPHI)\Imports;$(DELPHI);c:\source\ivex\commo
n;$(DELPHI)\ics\delphi\vc32

Isn't this correct? Must not be correct, because I still get the error
during compilation!

Thanks!

--Saige

At 06:02 PM 06/28/2000 +0200, you wrote:
>Saige,
>
>This error message means Delphi can not find WSocket.pas, just add the path
>where WSocket.pas is inside to your search path.
>
>rgds, Wilfried
>
>-----Original Message-----
>From: twsocket-admin@elists.org [mailto:twsocket-admin@elists.org]On Behalf
>Of Saige Losli
>Sent: woensdag 28 juni 2000 17:24
>To: twsocket@elists.org
>Subject: [twsocket] WSocket.dcu file not found
>
>
>Hello,
>
>I am working on my first project using ICS since upgrading from Delphi 3 to
>4. When I try to compile a project that has a WSocket on it, I get the error
>message, "[Fatal Error] quote_frm.pas(9): File not found: 'WSocket.dcu'"
>
>Apparently Roel Speerstra had the same problem on May 14, 1999, when he
>said:
>
>Hallo compagnon-users,
>i recently upgraded from Delphi 3 to Delphi 4. Now i'm trying to get the
>FTP-component to work again.
>(Perhaps this question is asked many times before...)
>When i try to compile a small ftp-program i'm building the compilation stops
>in the uses-clause (right after the interface-statement) in front of the
>FTPCLI line, saying [Fatal Error] main.pas(28): File not found:
>'WSocket.dcu'.
>
>To which Michael Thompson replied:
>
>I think you need to do a FULL compile on all sources..
>
>And Francois Piette said:
>
>You have to reinstall ICS components in Delphi 4.
>
>I have tried both a FULL compile (build) and fully re-installing the ICS,
>but I still get the same results. I am using Delphi 4 with Update Pack 3 on
>Windows 2000 Professional.
>
>Any ideas? Thank you.
>
>--Saige
>
>-----
>Saige Losli                         Ivex Design International
>Tel (503) 531-3555                  http://www.ivex.com
>
>
>_______________________________________________
>TWSocket mailing list [http://elists.org/mailman/listinfo/twsocket]
>Visit our website at http://www.rtfm.be/fpiette/indexuk.htm 
> 
-----
Saige Losli                         Ivex Design International
Tel (503) 531-3555                  http://www.ivex.com