[twsocket] WSocket.dcu file not found

Saige Losli saigel@ivex.com
Wed, 28 Jun 2000 08:24:04 -0700


Hello,

I am working on my first project using ICS since upgrading from Delphi 3 to 4. When I try to compile a project that has a WSocket on it, I get the error message, "[Fatal Error] quote_frm.pas(9): File not found: 'WSocket.dcu'"

Apparently Roel Speerstra had the same problem on May 14, 1999, when he said:

Hallo compagnon-users,
i recently upgraded from Delphi 3 to Delphi 4. Now i'm trying to get the FTP-component to work again.
(Perhaps this question is asked many times before...)
When i try to compile a small ftp-program i'm building the compilation stops in the uses-clause (right after the interface-statement) in front of the FTPCLI line, saying [Fatal Error] main.pas(28): File not found: 'WSocket.dcu'.

To which Michael Thompson replied:

I think you need to do a FULL compile on all sources..

And Francois Piette said:

You have to reinstall ICS components in Delphi 4.

I have tried both a FULL compile (build) and fully re-installing the ICS, but I still get the same results. I am using Delphi 4 with Update Pack 3 on Windows 2000 Professional.

Any ideas? Thank you.

--Saige
-----
Saige Losli                         Ivex Design International
Tel (503) 531-3555                  http://www.ivex.com