[twsocket] FTP Put over WebRamp hangs (second post)

SARGENT JEREMY JSARGENT@singular.gr
Fri, 9 Jun 2000 16:43:08 +0300


Ummm....OK so it works with MS-FTP.

Can you do a dir using ICS FTP?
Can you read files using ICS?
Are you sure that it really has connected?
Is it connected to YOUR FTP server?

Where can we get webramp for free to try out so we
can help?

BTW: how do you know it will work ok with other
libraries if you don't know what the problem is?

I hope I was constructive.

> -----Original Message-----
> From: SARGENT JEREMY [mailto:JSARGENT@singular.gr]
> Sent: Παρασκευή, 9 Ιουνίου 2000 4:17 μμ
> To: 'twsocket@elists.org'
> Subject: RE: [twsocket] FTP Put over WebRamp hangs (second post)
> 
> 
> ICS works with other proxy servers. Why isn't it
> a problem with WebRamp?
> 
> > -----Original Message-----
> > From: William Sorensen [mailto:tzimisce@home.com]
> > Sent: Παρασκευή, 9 Ιουνίου 2000 4:14 μμ
> > To: twsocket@elists.org
> > Subject: [twsocket] FTP Put over WebRamp hangs (second post)
> > 
> > 
> > So no one, not even Francois, has a clue?  This strongly 
> > appears to be a 
> > problem with ICS, as Microsoft's console-based FTP works just 
> > fine.  Right 
> > now, we're evaluating other libraries to find a replacement for 
> > ICS.  Recommendations are welcome.
> > 
> > >Date: Mon, 05 Jun 2000 13:07:40 -0500
> > >To: twsocket@elists.org
> > >From: William Sorensen <tzimisce@home.com>
> > >Subject: [twsocket] FTP Put over WebRamp hangs
> > >
> > >Using TFtpClient from ICS revision dated April 02, 2000, 
> Delphi 5.01:
> > >
> > >My FTP application works fine on most systems.  One client, 
> > however, has a 
> > >product called WebRamp installed.  Apparently this is a 
> > proxy server that 
> > >allows multiple workstations to share a single Internet 
> > connection.  They 
> > >do not have the high-end version of WebRamp with firewall 
> > support.  On 
> > >their system, they can connect to our FTP server but cannot 
> > Put a file.
> > >
> > >They connect, login, enter password, obtain directory, etc. 
> > without problems.
> > >
> > >My code calls the PutAsync method.  The logs show:
> > >
> > > > STOR UPLOAD
> > >  < 150 Opening BINARY mode data connection for UPLOAD.
> > >
> > >Then it sits until it times out or the user aborts it.  No 
> > events fire.
> > >
> > >I have tried this with Passive mode on and off, with the 
> > same results.
> > >
> > >The client can connect to the same FTP server and upload a 
> > file with no 
> > >problems if they use the command-line FTP that Microsoft 
> > provides with 
> > >Windows 9x.
> > >
> > >Any help would be appreciated.
> > 
> > ++++
> > Bill Sorensen, Programmer/Analyst, ASI/EDI Inc.
> > tzimisce@home.com
> > www.asiedi.com
> > 
> > 
> > _______________________________________________
> > TWSocket mailing list [http://elists.org/mailman/listinfo/twsocket]
> > Visit our website at http://www.rtfm.be/fpiette/indexuk.htm 
> > 
> 
> 
> _______________________________________________
> TWSocket mailing list [http://elists.org/mailman/listinfo/twsocket]
> Visit our website at http://www.rtfm.be/fpiette/indexuk.htm 
> 
>